summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGoffredo Baroncelli <kreijack@inwind.it>2012-06-09 07:52:10 +0200
committerDavid Sterba <dsterba@suse.cz>2013-03-19 18:21:41 +0100
commitf243fcd1b2aa55ffadfbcc032c66dedbee56e79e (patch)
tree8e126cca1a803b152d9e2b0e351c6100470f81d1 /Makefile
parentcf7e3472d72c912bef0ccb72cc609cf95233ee86 (diff)
Removing btrfsctl, btrfs-vol, btrfs-show
With the commit 002d021c (committed October 2011) btrfsctl, btrfs-vol, btrfs-show were declared deprecated. The last patches related to these commands are dated December 2010. These tools are replaced by the "btrfs" tool in all the functionality. This commit removes all the related code. Signed-off-by: Goffredo Baroncelli <kreijack@inwind.it> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 1 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index afbf55dd..5353641a 100644
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,7 @@ endif
MAKEOPTS = --no-print-directory Q=$(Q)
-progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck \
+progs = mkfs.btrfs btrfs-debug-tree btrfsck \
btrfs btrfs-map-logical btrfs-image btrfs-zero-log btrfs-convert \
btrfs-find-root btrfstune btrfs-show-super
@@ -127,18 +127,6 @@ btrfs-find-root.static: $(static_objects) find-root.static.o
@echo " [LD] $@"
$(Q)$(CC) $(STATIC_CFLAGS) -o btrfs-find-root.static find-root.static.o $(static_objects) $(STATIC_LDFLAGS) $(STATIC_LIBS)
-btrfsctl: $(objects) $(libs) btrfsctl.o
- @echo " [LD] $@"
- $(Q)$(CC) $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)
-
-btrfs-vol: $(objects) $(libs) btrfs-vol.o
- @echo " [LD] $@"
- $(Q)$(CC) $(CFLAGS) -o btrfs-vol btrfs-vol.o $(objects) $(LDFLAGS) $(LIBS)
-
-btrfs-show: $(objects) $(libs) btrfs-show.o
- @echo " [LD] $@"
- $(Q)$(CC) $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
-
# For backward compatibility, 'btrfs' changes behaviour to fsck if it's named 'btrfsck'
btrfsck: btrfs
@echo " [LN] $@"