summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2014-04-04 16:36:40 +0200
committerDavid Sterba <dsterba@suse.cz>2014-04-22 14:15:25 +0200
commitfd287d868f122c59d994ae38977fa3d552f86673 (patch)
tree60bda9483e2be7d31d3d1bacc31ccb7e636183d1 /Makefile
parenta11cd2b591f76373f75c1197501d7e816a663c9a (diff)
btrfs-progs: add separate make target to clean docs
Regenerating the asciidoc takes much longer now and makes quick build tests long. There's separate clean-doc target for that and clean-all that cleans docs and sources. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 6ae0164f..51d53fad 100644
--- a/Makefile
+++ b/Makefile
@@ -55,9 +55,9 @@ btrfs_convert_libs = -lext2fs -lcom_err
btrfs_image_libs = -lpthread
btrfs_fragment_libs = -lgd -lpng -ljpeg -lfreetype
-SUBDIRS = Documentation
-BUILDDIRS = $(patsubst %,build-%,$(SUBDIRS))
-INSTALLDIRS = $(patsubst %,install-%,$(SUBDIRS))
+SUBDIRS =
+BUILDDIRS = $(patsubst %,build-%,$(SUBDIRS)) build-Documentation
+INSTALLDIRS = $(patsubst %,install-%,$(SUBDIRS)) install-Documentation
CLEANDIRS = $(patsubst %,clean-%,$(SUBDIRS))
.PHONY: $(SUBDIRS)
@@ -119,7 +119,7 @@ endif
@echo " [CC] $@"
$(Q)$(CC) $(AM_CFLAGS) $(STATIC_CFLAGS) -c $< -o $@
-all: $(progs) manpages $(BUILDDIRS)
+all: $(progs) $(BUILDDIRS)
$(SUBDIRS): $(BUILDDIRS)
$(BUILDDIRS):
@echo "Making all in $(patsubst build-%,%,$@)"
@@ -222,6 +222,8 @@ send-test: $(objects) $(libs) send-test.o
manpages:
$(Q)$(MAKE) $(MAKEOPTS) -C Documentation
+clean-all: clean-doc clean
+
clean: $(CLEANDIRS)
@echo "Cleaning"
$(Q)rm -f $(progs) cscope.out *.o *.o.d btrfs-convert btrfs-image btrfs-select-super \
@@ -230,6 +232,10 @@ clean: $(CLEANDIRS)
version.h $(check_defs) \
$(libs) $(lib_links)
+clean-doc:
+ @echo "Cleaning Documentation"
+ $(Q)$(MAKE) $(MAKEOPTS) -C Documentation clean
+
$(CLEANDIRS):
@echo "Cleaning $(patsubst clean-%,%,$@)"
$(Q)$(MAKE) $(MAKEOPTS) -C $(patsubst clean-%,%,$@) clean