summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAndreas Philipp <philipp.andreas@gmail.com>2011-07-02 00:44:38 +0200
committerChris Mason <chris.mason@oracle.com>2011-10-25 09:18:59 -0400
commitfd635cdc2d34ed8a1314dc1eef410e0259a796cd (patch)
tree0c7ecb0094c100e5f36b6aec760feb647de59c63 /Makefile
parent3aa511e7ed0a565eb9b21ce7f8d4b192851ad023 (diff)
some style/layout changes
Just do a few simple style/layout changes to make the makefile look better. Signed-off-by: Andreas Philipp <philipp.andreas@gmail.com> Signed-off-by: Hugo Mills <hugo@carfax.org.uk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 3a1e3080..22bae25f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-CC=gcc
+CC = gcc
AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
CFLAGS = -g -Werror -Os
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
@@ -6,25 +6,23 @@ objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
inode-map.o crc32c.o rbtree.o extent-cache.o extent_io.o \
volumes.o utils.o btrfs-list.o btrfslabel.o
-#
-CHECKFLAGS=-D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ -Wbitwise \
- -Wuninitialized -Wshadow -Wundef
+CHECKFLAGS= -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ -Wbitwise \
+ -Wuninitialized -Wshadow -Wundef
DEPFLAGS = -Wp,-MMD,$(@D)/.$(@F).d,-MT,$@
-INSTALL= install
+INSTALL = install
prefix ?= /usr/local
bindir = $(prefix)/bin
-LIBS=-luuid
+LIBS = -luuid
progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck \
- btrfs \
- btrfs-map-logical
+ btrfs btrfs-map-logical
# make C=1 to enable sparse
ifdef C
- check=sparse $(CHECKFLAGS)
+ check = sparse $(CHECKFLAGS)
else
- check=ls
+ check = ls
endif
.c.o: