summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2011-10-27 16:25:12 -0400
committerChris Mason <chris.mason@oracle.com>2011-10-27 16:25:12 -0400
commitff91b185f7ddad0f16fb0be4c6713d65daf1b03e (patch)
tree466c0566f5f3e08fe1beddd21de8f43f7312cc64 /Makefile
parentba1aa28496cf2a2c7ffff0521c6c858a0505d4c2 (diff)
restore: deal with holes and set i_size correctly
This changes restore to set the i_size of the files it copies out based on the size in the inode. It also changes it to skip over holes. Signed-off-by: Chris Mason <chris.mason@oracle.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e85c7266..a5024f1b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
CC = gcc
AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
-CFLAGS = -g -Os
+CFLAGS = -g -O0
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o file-item.o inode-item.o \
inode-map.o crc32c.o rbtree.o extent-cache.o extent_io.o \