summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJan Schmidt <list.btrfs@jan-o-sch.net>2013-03-21 17:02:40 +0100
committerDavid Sterba <dsterba@suse.cz>2013-04-09 18:43:32 +0200
commit08fecd7658610d8572b04280d6708960a3265a88 (patch)
treea34dff60a13f72fffe7fe763f0182e40ce590960 /Makefile
parentb0029a96f2c6a178183602e1ff11d8d3660ee8fb (diff)
Btrfs-progs: add btrfs-crc tool
This tool can be used to compute btrfs' style crc32c checksums for filenames as done by the kernel. Additionally, there is -c mode to do a brute force search for file names with a given checksum. Signed-off-by: Jan Schmidt <list.btrfs@jan-o-sch.net>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a270e9ca..dcd3a0e2 100644
--- a/Makefile
+++ b/Makefile
@@ -174,6 +174,10 @@ btrfs-image: $(objects) $(libs) btrfs-image.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o btrfs-image $(objects) btrfs-image.o -lpthread -lz $(LDFLAGS) $(LIBS)
+btrfs-crc: btrfs-crc.o $(libs)
+ @echo " [LD] $@"
+ $(Q)$(CC) $(CFLAGS) -o btrfs-crc btrfs-crc.o $(LDFLAGS) $(LIBS)
+
dir-test: $(objects) $(libs) dir-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o dir-test $(objects) dir-test.o $(LDFLAGS) $(LIBS)