summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2018-02-08 15:34:04 +0100
committerDavid Sterba <dsterba@suse.com>2018-02-13 15:41:32 +0100
commit04cd2c0bcac7129026c80661933b4ab97d4ab9ca (patch)
tree75b5c7350131ca7b1d8c0cfc9f3b0d0115157449 /Makefile
parenteb2fe7d1c476ebfa434ec2cf8afd1b52cce0f28e (diff)
btrfs-progs: rework testsuite export
Move the testsuite to tests/ and make the tarball generation more deterministic. As there could be many random temporary files left in the test directories, we can't just copy them. Use 'git ls-tree' to filter just what we want, this needs a slight extension of the file list specification. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 3a5e01da..65ec1009 100644
--- a/Makefile
+++ b/Makefile
@@ -333,7 +333,7 @@ test: test-fsck test-mkfs test-convert test-misc test-fuzz test-cli
testsuite: btrfs-corrupt-block fssum
@echo "Export tests as a package"
- $(Q)bash tests/export-tests.sh
+ $(Q)cd tests && ./export-testsuite.sh
#
# NOTE: For static compiles, you need to have all the required libs