summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNikolay Borisov <nborisov@suse.com>2018-03-27 10:45:46 +0300
committerDavid Sterba <dsterba@suse.com>2018-04-24 13:00:10 +0200
commit631bf9f2b9aab3ac84a2646b04dbe7ec303a7ef1 (patch)
tree37a4d6ce86eaa056c3cf825f7fc5da49912ee0b8 /Makefile
parent5a87a95115a0f992ef4d3ef9ad480d8cf3bb27ec (diff)
btrfs-progs: Remove deprecated btrfs-calc-size tool
Its function has been superseded by btrfs inspect-internal tree-stats. Just remove it. Deprecated since 4.8. Issue: #97 Signed-off-by: Nikolay Borisov <nborisov@suse.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index a63f70ec..0470f2e0 100644
--- a/Makefile
+++ b/Makefile
@@ -215,7 +215,7 @@ progs_install = btrfs mkfs.btrfs btrfs-map-logical btrfs-image \
btrfs-select-super
# other tools, not built by default
-progs_extra = btrfs-fragments btrfs-calc-size
+progs_extra = btrfs-fragments
progs_static = $(foreach p,$(progs),$(p).static)
@@ -228,7 +228,6 @@ endif
btrfs_convert_cflags = -DBTRFSCONVERT_EXT2=$(BTRFSCONVERT_EXT2)
btrfs_convert_cflags += -DBTRFSCONVERT_REISERFS=$(BTRFSCONVERT_REISERFS)
btrfs_fragments_libs = -lgd -lpng -ljpeg -lfreetype
-btrfs_calc_size_objects = cmds-inspect-tree-stats.o
cmds_restore_cflags = -DBTRFSRESTORE_ZSTD=$(BTRFSRESTORE_ZSTD)
CHECKER_FLAGS += $(btrfs_convert_cflags)