summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGu Jinxiang <gujx@cn.fujitsu.com>2018-02-08 14:34:18 +0800
committerDavid Sterba <dsterba@suse.com>2018-02-13 15:41:32 +0100
commiteb2fe7d1c476ebfa434ec2cf8afd1b52cce0f28e (patch)
tree1d4025a45b551910f4ddb402e3b97235262ef456 /Makefile
parentd5238ad71140b0222aa805382c679599b2c91025 (diff)
btrfs-progs: Add make testsuite command for export tests
Export the testsuite files to a separate tar. Since fsck tests depend on btrfs-corrupt-block, and misc tests depends on both btrfs-corrupt-block and fssum, so set it as prerequisites for package commad. Because, althougth fssum can be generated by source that are all in tests directory, and has no rely on the btrfs's structure. But btrfs-corrupt-block deeply relys on btrfs's structure. For consistency, at the present stage, generete the two when create test tar. Signed-off-by: Gu Jinxiang <gujx@cn.fujitsu.com> [ applied without changes, the generated tarball will be different from the one after the follow up commits ] Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 39d1d77b..3a5e01da 100644
--- a/Makefile
+++ b/Makefile
@@ -331,6 +331,10 @@ test-inst: all
test: test-fsck test-mkfs test-convert test-misc test-fuzz test-cli
+testsuite: btrfs-corrupt-block fssum
+ @echo "Export tests as a package"
+ $(Q)bash tests/export-tests.sh
+
#
# NOTE: For static compiles, you need to have all the required libs
# static equivalent available