summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2011-10-27 22:02:19 -0400
committerChris Mason <chris.mason@oracle.com>2011-10-27 22:38:02 -0400
commit18c970767f21714efcbfe8121d30962c9b262545 (patch)
tree932985e764a4cedbc5b83b15421bb8d180f80d74 /Makefile
parentb670b9285efb2cd5b8a1668d6e80727d03e2a3d2 (diff)
btrfs-progs: add a utility to corrupt a single block
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a5024f1b..96e20020 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ LIBS=-luuid
RESTORE_LIBS=-lz
progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck \
- btrfs btrfs-map-logical restore find-root calc-size
+ btrfs btrfs-map-logical restore find-root calc-size btrfs-corrupt-block
# make C=1 to enable sparse
ifdef C
@@ -79,6 +79,9 @@ btrfstune: $(objects) btrfstune.o
btrfs-map-logical: $(objects) btrfs-map-logical.o
$(CC) $(CFLAGS) -o btrfs-map-logical $(objects) btrfs-map-logical.o $(LDFLAGS) $(LIBS)
+btrfs-corrupt-block: $(objects) btrfs-corrupt-block.o
+ $(CC) $(CFLAGS) -o btrfs-corrupt-block $(objects) btrfs-corrupt-block.o $(LDFLAGS) $(LIBS)
+
btrfs-image: $(objects) btrfs-image.o
$(CC) $(CFLAGS) -o btrfs-image $(objects) btrfs-image.o -lpthread -lz $(LDFLAGS) $(LIBS)