summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNaohiro Aota <naohiro.aota@wdc.com>2017-09-14 19:10:56 +0900
committerDavid Sterba <dsterba@suse.com>2017-09-25 15:17:45 +0200
commit3efd322db238abcee7f8dddd6d5af7f69fc3fac4 (patch)
tree8c5f95cf5e6d1cff02c380e1b35268681ca8e972 /Makefile
parentfd8c78a47c2448891db57c867b0f16c4367fa501 (diff)
btrfs-progs: build: omit unnecessary -MD flag
According to gcc(1), "-MD is equivalent to -M -MF file, except that -E is not implied." Since the rule in the Makefile is just generating dependency file and not building object file, it is no use to have "-MD" here. Also, it's overridden and conflicting with the following "-MM" flag. I guess we can drop it. Signed-off-by: Naohiro Aota <naohiro.aota@wdc.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9b7ac2f4..922baff7 100644
--- a/Makefile
+++ b/Makefile
@@ -265,7 +265,7 @@ else
endif
%.o.d: %.c
- $(Q)$(CC) -MD -MM -MG -MF $@ -MT $(@:.o.d=.o) -MT $(@:.o.d=.static.o) -MT $@ $(CFLAGS) $<
+ $(Q)$(CC) -MM -MG -MF $@ -MT $(@:.o.d=.o) -MT $(@:.o.d=.static.o) -MT $@ $(CFLAGS) $<
#
# Pick from per-file variables, btrfs_*_cflags