summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2014-12-12 15:49:26 +0100
committerDavid Sterba <dsterba@suse.cz>2014-12-12 16:21:42 +0100
commit4f9d8b1ffafd4ce1bf1c4c805a22bd089ade9861 (patch)
tree30a6e8fb3782a30d79c0dd0b60a4f496f04e223b /Makefile
parent6856b0a4cab6eae794f0fe012391fa76a8dd3b4e (diff)
btrfs-progs: tests: build prerequisities, btrfs-image and btrfs
Build required utilities from the main Makefile and just check in the test scripts. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 04d2c37d..e1b0a88c 100644
--- a/Makefile
+++ b/Makefile
@@ -140,7 +140,7 @@ $(BUILDDIRS):
@echo "Making all in $(patsubst build-%,%,$@)"
$(Q)$(MAKE) $(MAKEOPTS) -C $(patsubst build-%,%,$@)
-test:
+test: btrfs btrfs-convert btrfs-image btrfs-corrupt-block
$(Q)for t in $(TESTS); do \
echo " [TEST] $$t"; \
bash tests/$$t || exit 1; \