summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorOmar Sandoval <osandov@fb.com>2018-03-29 00:53:55 -0700
committerDavid Sterba <dsterba@suse.com>2018-03-30 22:54:41 +0200
commit660adc0e1cad9fa46d4f689ae9c5c3202041863f (patch)
tree507579b6bdb0a21ba5ea9337d4d63d786805469b /Makefile
parentf5dd778f5299088f89d380ce922a84d77a98b9d6 (diff)
libbtrfsutil: use local mkfs.btrfs for tests if it exists
The system might not have mkfs installed at all. Signed-off-by: Omar Sandoval <osandov@fb.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8afc8f6e..699f864d 100644
--- a/Makefile
+++ b/Makefile
@@ -357,7 +357,7 @@ testsuite: btrfs-corrupt-block fssum
$(Q)cd tests && ./export-testsuite.sh
ifeq ($(PYTHON_BINDINGS),1)
-test-libbtrfsutil: libbtrfsutil_python
+test-libbtrfsutil: libbtrfsutil_python mkfs.btrfs
$(Q)cd libbtrfsutil/python; \
LD_LIBRARY_PATH=../.. $(PYTHON) -m unittest discover -v tests