summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-01-30 13:29:22 +0100
committerDavid Sterba <dsterba@suse.com>2017-03-08 13:00:46 +0100
commit663253415f2315779c246b889e2030681ff9efae (patch)
treedd4c66d62044c30f76323cf2b60871d5969f7905 /Makefile
parent732056e3d3a35fad43515d5d7a87dc8572ae097e (diff)
btrfs-progs: build: add rule for building cscope index
Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 18e4e82b..8354224b 100644
--- a/Makefile
+++ b/Makefile
@@ -43,6 +43,7 @@ $(error Makefile.inc not generated, please configure first)
endif
TAGS_CMD := ctags
+CSCOPE_CMD := cscope -u -b -c -q
include Makefile.extrawarn
@@ -475,11 +476,16 @@ tags: FORCE
@echo " [TAGS] $(TAGS_CMD)"
$(Q)$(TAGS_CMD) *.[ch] image/*.[ch] convert/*.[ch] mkfs/*.[ch]
+cscope: FORCE
+ @echo " [CSCOPE] $(CSCOPE_CMD)"
+ $(Q)ls -1 *.[ch] image/*.[ch] convert/*.[ch] mkfs/*.[ch] > cscope.files
+ $(Q)$(CSCOPE_CMD)
+
clean-all: clean clean-doc clean-gen
clean: $(CLEANDIRS)
@echo "Cleaning"
- $(Q)$(RM) -f -- $(progs) cscope.out *.o *.o.d \
+ $(Q)$(RM) -f -- $(progs) *.o *.o.d \
kernel-lib/*.o kernel-lib/*.o.d \
image/*.o image/*.o.d \
convert/*.o convert/*.o.d \
@@ -499,6 +505,7 @@ clean-gen:
$(Q)$(RM) -rf -- version.h config.status config.cache connfig.log \
configure.lineno config.status.lineno Makefile.inc \
Documentation/Makefile tags \
+ cscope.files cscope.out cscope.in.out cscope.po.out \
config.log config.h config.h.in~ aclocal.m4 \
configure autom4te.cache/ config/