summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMark Fasheh <mfasheh@suse.de>2013-01-30 14:50:25 -0800
committerDavid Sterba <dsterba@suse.cz>2013-02-13 11:53:21 +0100
commit66819df285e330b52b5b43d1e273f9362b499193 (patch)
tree77d25e09d51f050f4b1720c331b6386387022d6c /Makefile
parentfac5b559a784cd50ae355bddae1ca2a850e4d39a (diff)
btrfs-progs: add send-test
send-test.c links against libbtrfs and uses the send functionality provided to decode and print a send stream to the console. Signed-off-by: Mark Fasheh <mfasheh@suse.de> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e83cf5b0..456dd4f2 100644
--- a/Makefile
+++ b/Makefile
@@ -164,6 +164,10 @@ ioctl-test: $(objects) ioctl-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o ioctl-test $(objects) ioctl-test.o $(LDFLAGS) $(LIBS)
+send-test: $(objects) send-test.o
+ @echo " [LD] $@"
+ $(Q)$(CC) $(CFLAGS) -o send-test $(objects) send-test.o $(LDFLAGS) $(LIBS) -lpthread
+
manpages:
$(Q)$(MAKE) $(MAKEOPTS) -C man
@@ -173,7 +177,7 @@ install-man:
clean :
@echo "Cleaning"
$(Q)rm -f $(progs) cscope.out *.o .*.d btrfs-convert btrfs-image btrfs-select-super \
- btrfs-zero-log btrfstune dir-test ioctl-test quick-test btrfs.static btrfsck \
+ btrfs-zero-log btrfstune dir-test ioctl-test quick-test send-test btrfs.static btrfsck \
version.h
$(Q)$(MAKE) $(MAKEOPTS) -C man $@