summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2018-04-04 16:04:59 +0200
committerDavid Sterba <dsterba@suse.com>2018-04-06 15:06:50 +0200
commit6cedd688115d85e6f14a43f7653378749ef31624 (patch)
tree5d18b3a8a19328c3b72fcdbc7207ee78deaff017 /Makefile
parentd0aafc51e4d1fcfd37e80712ba7b404ddde2a7d6 (diff)
btrfs-progs: build: Do not use cp -a to install library links
Using cp -a to install files will preserve the ownership of the original files (if possible), which is typically not wanted. E.g. if the files were built by a normal user, but are being installed by root, then the installed files would maintain the UIDs/GIDs of the user that built the files rather than be owned by root. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Reviewed-by: Anand Jain <anand.jain@oracle.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index fbd6677a..5ba76d2e 100644
--- a/Makefile
+++ b/Makefile
@@ -642,7 +642,7 @@ install: $(libs) $(progs_install) $(INSTALLDIRS)
$(LN_S) -f btrfs $(DESTDIR)$(bindir)/btrfsck
$(INSTALL) -m755 -d $(DESTDIR)$(libdir)
$(INSTALL) $(libs) $(DESTDIR)$(libdir)
- cp -a $(lib_links) $(DESTDIR)$(libdir)
+ cp -d $(lib_links) $(DESTDIR)$(libdir)
$(INSTALL) -m755 -d $(DESTDIR)$(incdir)/btrfs
$(INSTALL) -m644 $(libbtrfs_headers) $(DESTDIR)$(incdir)/btrfs
$(INSTALL) -m644 libbtrfsutil/btrfsutil.h $(DESTDIR)$(incdir)