summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2013-01-30 19:02:21 +0100
committerDavid Sterba <dsterba@suse.cz>2013-01-31 18:55:34 +0100
commit7aaf00fc2bc1f90ff358df1f880bea16a96678ab (patch)
treecced61eca9cf61a1e970d0e0ee099dfab9c2bc62 /Makefile
parent680a80ece109a2994ac9c59511fb8974ace12fd9 (diff)
btrfs-progs: fix parallel build
Parallel build may fail due to late creation of version.h, fix the rule name that does not match the filename. Signed-off-by: David Sterba <dsterba@suse.cz> Reviewed-by: Eri Sandeen <sandeen@redhat.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 6df402cd..bef1e13b 100644
--- a/Makefile
+++ b/Makefile
@@ -52,9 +52,9 @@ endif
$(Q)$(CC) $(DEPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c $<
-all: version $(progs) manpages
+all: version.h $(progs) manpages
-version:
+version.h:
$(Q)bash version.sh
btrfs: $(objects) btrfs.o help.o $(cmds_objects)