summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2008-01-04 11:29:55 -0500
committerDavid Woodhouse <dwmw2@hera.kernel.org>2008-01-04 11:29:55 -0500
commit806528b8755f0586b4846d0ef29f2fec56662757 (patch)
treee9d3cf274972556fefed1c573396b6e06df1ad16 /Makefile
parent84b99666be01205ffea5cb2740c7b6a917cb38a1 (diff)
Add Yan Zheng's ext3->btrfs conversion program
run make convert to build it, the program is named btrfs-convert and is not installed by default.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 62a43b93..63514021 100644
--- a/Makefile
+++ b/Makefile
@@ -47,8 +47,11 @@ dir-test: $(objects) dir-test.o
quick-test: $(objects) quick-test.o
gcc $(CFLAGS) -o quick-test $(objects) quick-test.o $(LDFLAGS)
+convert: $(objects) convert.o utils.o
+ gcc $(CFLAGS) -o btrfs-convert $(objects) convert.o utils.o -luuid -lext2fs $(LDFLAGS)
+
clean :
- rm -f $(progs) cscope.out *.o .*.d
+ rm -f $(progs) cscope.out *.o .*.d btrfs-convert
install: $(progs)
$(INSTALL) -m755 -d $(DESTDIR)$(bindir)