summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2007-05-22 10:07:10 -0400
committerDavid Woodhouse <dwmw2@hera.kernel.org>2007-05-22 10:07:10 -0400
commit832427bdbad9c2e7ad9635ddc1cad05563d9d16a (patch)
tree0eed70223aed40c0e8459daa70e27d7394fac7ea /Makefile
parent723eafc64706679e8932b6cd2fb66005be4f7387 (diff)
cleanup warnings found with -O2
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ff7e09ef..2ca356f2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
CC=gcc
-CFLAGS = -g -Wall -Werror
+CFLAGS = -O2 -g -Wall -fno-strict-aliasing -Werror
headers = radix-tree.h ctree.h disk-io.h kerncompat.h print-tree.h list.h \
transaction.h ioctl.h
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \