summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-03-14 18:53:29 +0100
committerDavid Sterba <dsterba@suse.com>2017-03-16 17:02:44 +0100
commit9a98589f00f8e8def668f9e3f76a0d44e525cff7 (patch)
treeb2ef7d7e3315ca74bddabd55254051d6955ab9c9 /Makefile
parentc2d3f549960e3a21196dc535e123b709abd55f34 (diff)
btrfs-progs: tests: add fssum utility
Copy from fstests, originally from git://git.kernel.org/pub/scm/linux/kernel/git/arne/far-progs.git Needs libcrypto to link but this check is now missing in configure. Signed-off-by: Jan Schmidt <list.btrfs@jan-o-sch.net> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index b6a49e0b..2e25f6cc 100644
--- a/Makefile
+++ b/Makefile
@@ -466,6 +466,11 @@ library-test.static: library-test.c messages.static.o $(libs_static)
@echo " [TEST CLEAN] $@"
$(Q)$(RM) -rf -- $(TMPD)
+fssum: tests/fssum.c
+ @echo " [LD] $@"
+ # FIXME: no configure-time check for libcrypto from SSL
+ $(Q)$(CC) $(CFLAGS) -o $@ $< -D__LINUX__ $(LDFLAGS) -lcrypto
+
test-build: test-build-pre test-build-real
test-build-pre:
@@ -502,7 +507,7 @@ clean: $(CLEANDIRS)
convert/*.o convert/*.o.d \
mkfs/*.o mkfs/*.o.d \
dir-test ioctl-test quick-test library-test library-test-static \
- btrfs.static mkfs.btrfs.static \
+ btrfs.static mkfs.btrfs.static fssum \
$(check_defs) \
$(libs) $(lib_links) \
$(progs_static) $(progs_extra)