summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYan Zheng <zheng.yan@oracle.com>2008-11-20 09:52:48 -0500
committerChris Mason <chris.mason@oracle.com>2008-11-20 09:52:48 -0500
commitaa62e84c84436593edb56c9b9c61fa701c69f80e (patch)
tree41d06e2caee4af7a1d8933d9481f80c95a84acf0 /Makefile
parent49bc666d5fcedc7221eeeef0499e21a45c3ca4ad (diff)
Btrfs image tool
This patch adds btrfs image tool. The image tool is a debugging tool that creates/restores btrfs metadump image. Signed-off-by: Yan Zheng <zheng.yan@oracle.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 840fca63..6e80a597 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,8 @@ prefix ?= /usr/local
bindir = $(prefix)/bin
LIBS=-luuid
-progs = btrfsctl btrfsck mkfs.btrfs debug-tree btrfs-show btrfs-vol btrfstune
+progs = btrfsctl btrfsck mkfs.btrfs debug-tree btrfs-show btrfs-vol \
+ btrfstune btrfs-image
# make C=1 to enable sparse
ifdef C
@@ -55,6 +56,9 @@ debug-tree: $(objects) debug-tree.o
btrfstune: $(objects) btrfstune.o
gcc $(CFLAGS) -o btrfstune $(objects) btrfstune.o $(LDFLAGS) $(LIBS)
+btrfs-image: $(objects) btrfs-image.o
+ gcc $(CFLAGS) -o btrfs-image $(objects) btrfs-image.o -lpthread -lz $(LDFLAGS) $(LIBS)
+
dir-test: $(objects) dir-test.o
gcc $(CFLAGS) -o dir-test $(objects) dir-test.o $(LDFLAGS) $(LIBS)