summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-03-19 08:33:24 +0300
committerDavid Sterba <dsterba@suse.cz>2013-03-19 18:21:30 +0100
commitcf7e3472d72c912bef0ccb72cc609cf95233ee86 (patch)
tree3e1c387f52f17ac8f18af4fb857829701f167374 /Makefile
parent87c09f70b5e334f68cc19c0514d412f666b4eb14 (diff)
Makefile: allow user set LDFLAGS for libbtrfs.so as well
Detected by gentoo's QA checker: * QA Notice: Files built without respecting LDFLAGS have been detected * Please include the following list of files in your report: * /usr/lib/libbtrfs.so.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9c195b33..afbf55dd 100644
--- a/Makefile
+++ b/Makefile
@@ -93,7 +93,8 @@ version.h:
$(libs_shared): $(libbtrfs_objects) $(lib_links) send.h
@echo " [LD] $@"
- $(Q)$(CC) $(CFLAGS) $(libbtrfs_objects) $(lib_LIBS) -shared -Wl,-soname,libbtrfs.so -o libbtrfs.so.0.1
+ $(Q)$(CC) $(CFLAGS) $(libbtrfs_objects) $(LDFLAGS) $(lib_LIBS) \
+ -shared -Wl,-soname,libbtrfs.so -o libbtrfs.so.0.1
$(libs_static): $(libbtrfs_objects)
@echo " [AR] $@"