summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-08-30 14:48:09 +0200
committerDavid Sterba <dsterba@suse.cz>2014-09-02 17:05:15 +0200
commitef208e98cea2918aedb78f182b24461b9a5c275f (patch)
tree662ebcd334e9834227bac6a889ec68f6bb4c8dd9 /Makefile
parent101a8e1326637d9da727f234722abe305d1729fd (diff)
btrfs-progs: Add support for DISABLE_DOCUMENTATION
This commit adds the support for a make variable named "DISABLE_DOCUMENTATION", which allows to disable the build of the documentation. This is useful in contexts where the tools needed to build the documentation are not necessarily available. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 73ef3868..28243dee 100644
--- a/Makefile
+++ b/Makefile
@@ -57,10 +57,15 @@ btrfs_image_libs = -lpthread
btrfs_fragments_libs = -lgd -lpng -ljpeg -lfreetype
SUBDIRS =
-BUILDDIRS = $(patsubst %,build-%,$(SUBDIRS)) build-Documentation
-INSTALLDIRS = $(patsubst %,install-%,$(SUBDIRS)) install-Documentation
+BUILDDIRS = $(patsubst %,build-%,$(SUBDIRS))
+INSTALLDIRS = $(patsubst %,install-%,$(SUBDIRS))
CLEANDIRS = $(patsubst %,clean-%,$(SUBDIRS))
+ifneq ($(DISABLE_DOCUMENTATION),1)
+BUILDDIRS += build-Documentation
+INSTALLDIRS += install-Documentation
+endif
+
.PHONY: $(SUBDIRS)
.PHONY: $(BUILDDIRS)
.PHONY: $(INSTALLDIRS)