summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2014-10-30 18:59:47 +0100
committerDavid Sterba <dsterba@suse.cz>2014-11-07 17:52:57 +0100
commiteffebebb42bb4263d8633b4252ce2ac573f1a7f8 (patch)
treead48f5716d1ad93a0daa74e146b314f80e787867 /Makefile
parent5005192611967685b081614047d637130fba5c82 (diff)
btrfs-progs: build, add basic build test for library
Basic test based on snapper code that uses the send stream API. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 203597c3..99b03658 100644
--- a/Makefile
+++ b/Makefile
@@ -240,6 +240,14 @@ send-test: $(objects) $(libs) send-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o send-test $(objects) send-test.o $(LDFLAGS) $(LIBS) -lpthread
+library-test: $(libs_shared) library-test.o
+ @echo " [LD] $@"
+ $(Q)$(CC) $(CFLAGS) -o library-test library-test.o $(LDFLAGS) -lbtrfs
+
+library-test.static: $(libs_static) library-test.o
+ @echo " [LD] $@"
+ $(Q)$(CC) $(CFLAGS) -o library-test-static library-test.o $(LDFLAGS) $(libs_static)
+
manpages:
$(Q)$(MAKE) $(MAKEOPTS) -C Documentation