summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorZhao Lei <zhaolei@cn.fujitsu.com>2016-05-13 11:44:53 +0800
committerDavid Sterba <dsterba@suse.com>2016-06-01 14:56:56 +0200
commit4bf9da999e6118f13b57451b07ff9a1e5c780496 (patch)
tree29e277b783fb1a697e6e06e337b0c09ad5f66fc9 /autogen.sh
parentbda3d67511a9b58cdd9ff704360b47622cf41dc8 (diff)
btrfs-progs: autogen: Don't show success message on fail
When autogen.sh failed, the success message is still in output: # ./autogen.sh ... configure.ac:131: error: possibly undefined macro: PKG_CHECK_VAR If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. Now type './configure' and 'make' to compile. # Fixed by check return value of autoconf. After patch: # ./autogen.sh ... configure.ac:132: error: possibly undefined macro: PKG_CHECK_VAR If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. # Signed-off-by: Zhao Lei <zhaolei@cn.fujitsu.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh7
1 files changed, 4 insertions, 3 deletions
diff --git a/autogen.sh b/autogen.sh
index 8b9a9cbe..a5f9af24 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -64,9 +64,10 @@ echo " automake: $(automake --version | head -1)"
chmod +x version.sh
rm -rf autom4te.cache
-aclocal $AL_OPTS
-autoconf $AC_OPTS
-autoheader $AH_OPTS
+aclocal $AL_OPTS &&
+autoconf $AC_OPTS &&
+autoheader $AH_OPTS ||
+exit 1
# it's better to use helper files from automake installation than
# maintain copies in git tree