summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorQu Wenruo <quwenruo@cn.fujitsu.com>2016-05-09 12:46:46 +0800
committerDavid Sterba <dsterba@suse.com>2016-06-07 18:15:19 +0200
commitde34a25eb30bbe4b41bdef714f69fd8057ece7a9 (patch)
treee7ad97cd69a673129aab6270e39d7b47d8085dcf /configure.ac
parent75bf151ba3d31af27ef7af10fef0ae97295d4318 (diff)
btrfs-progs: convert: add compatibility layer for e2fsprogs < 1.42
The new convert framework copies code from current dumpe2fs, which uses BIGALLOC feature introduced in e2fsprogs v1.42. While there are a lot of enterprise distributions which are still using v1.41 e2fsprogs, this will cause compile error for them. This patch introduces backward compatibility for new convert framework, by manually introduce macros for ext2 BIGALLOC feature. Signed-off-by: Qu Wenruo <quwenruo@cn.fujitsu.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6b68c090..c79472cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,7 +105,11 @@ AS_IF([test "x$enable_convert" = xyes], [DISABLE_BTRFSCONVERT=0], [DISABLE_BTRFS
AC_SUBST([DISABLE_BTRFSCONVERT])
if test "x$enable_convert" = xyes; then
- PKG_CHECK_MODULES(EXT2FS, [ext2fs >= 1.41])
+ PKG_CHECK_MODULES(EXT2FS, [ext2fs >= 1.42],,
+ [PKG_CHECK_MODULES(EXT2FS, [ext2fs],
+ [AC_DEFINE([HAVE_OLD_E2FSPROGS], [1],
+ [E2fsprogs does not support BIGALLOC])]
+ )])
PKG_CHECK_MODULES(COM_ERR, [com_err])
fi