summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-10-12 13:08:54 +0100
committerDavid Sterba <dsterba@suse.com>2017-10-13 20:15:51 +0200
commit2e5d35409a549c1876bc071f2f369de8ab5df60c (patch)
tree1ac2224200e40854b15953f8b507d37c5606d640 /configure.ac
parent5a69c58be683f3b420dc67257c9a95191023c002 (diff)
btrfs-progs: build: allow '--with-convert=' to accept comma-separated values
Before the change configure refused to accept it's defaults explicitly: $ ./configure --enable-convert --with-convert=ext2,reiserfs ... configure: error: unknown tokens for --with-convert: , After the change both converters are enabled: $ ./configure --enable-convert --with-convert=ext2,reiserfs ... btrfs-convert: yes (ext2,reiserfs) Cc: linux-btrfs@vger.kernel.org Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f273bbe9..adceafc3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,7 +148,7 @@ AC_SUBST([BTRFSCONVERT_EXT2])
AC_SUBST([BTRFSCONVERT_REISERFS])
# catch typos
-tmp=$(echo "$with_convert" | sed -e 's/auto//' | sed -e 's/ext2//' | sed -e 's/reiserfs//' | sed -e 's/,\+/,/')
+tmp=$(echo "$with_convert" | sed -e 's/auto//' | sed -e 's/ext2//' | sed -e 's/reiserfs//' | sed -e 's/,\+//')
if ! test "x$tmp" = "x"; then
AC_MSG_ERROR([unknown tokens for --with-convert: $tmp])
fi