summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2018-02-19 18:13:46 +0100
committerDavid Sterba <dsterba@suse.com>2018-02-19 18:13:46 +0100
commitd62bd380797d3a990b2229ea6c16956972f7dfe0 (patch)
tree2cebb95310e59a0869793c2440729468bfa3b5be /configure.ac
parent3097f02c948f69f520c565ff8f8ba476aa6edb88 (diff)
btrfs-progs: build: configure.ac hard-codes the pkg-config command
Right now the pkg-config command is hard-coded in configure.ac, which may result in build errors on system and cross environments that have prefixed toolchains, e.g. /usr/x86_64-pc-linux-gnu/bin/x86_64-pc-linux-gnu-pkg-config. Please see the attached patch, it has been written a while ago but it seems it hasn't been submitted for upstream inclusion. 0001-configure.ac-Consistently-use-PKG_CONFIG.txt Submitted by Timo Gurr. Author: Wulf C. Krueger <philantrop@exherbo.org> Issue: #101 Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 56d17c3a..46f22a4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,8 +56,8 @@ dnl
dnl Calls pkg-config --static
dnl
AC_DEFUN([PKG_STATIC], [
- if AC_RUN_LOG([pkg-config --exists --print-errors "$2"]); then
- $1=`pkg-config --libs --static "$2"`
+ if AC_RUN_LOG([${PKG_CONFIG} --exists --print-errors "$2"]); then
+ $1=`${PKG_CONFIG} --libs --static "$2"`
AC_SUBST([$1])
else
AC_MSG_ERROR([pkg-config description of $2, needed for static build, is not available])
@@ -214,8 +214,8 @@ AC_SUBST(BTRFSRESTORE_ZSTD)
# Our udev rule gives us the friendly dm names but isn't required (or valid)
# on earlier releases.
UDEVDIR=
-if pkg-config udev --atleast-version 190; then
- UDEVDIR="$(pkg-config udev --variable=udevdir)"
+if ${PKG_CONFIG} udev --atleast-version 190; then
+ UDEVDIR="$(${PKG_CONFIG} udev --variable=udevdir)"
fi
AC_SUBST(UDEVDIR)