summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhao Lei <zhaolei@cn.fujitsu.com>2016-05-13 11:44:52 +0800
committerDavid Sterba <dsterba@suse.com>2016-06-01 14:56:56 +0200
commitf34d10bbe92b52c87a82bd978a15df1532745f9f (patch)
treec3f08d777e5fe02f95a25728241ebb175eba995c /configure.ac
parent4bf9da999e6118f13b57451b07ff9a1e5c780496 (diff)
btrfs-progs: autogen: Make build success in CentOS 6 and 7
btrfs-progs build failed in CentOS 6 and 7: #./autogen.sh ... configure.ac:131: error: possibly undefined macro: PKG_CHECK_VAR If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. ... Seems PKG_CHECK_VAR is new in pkgconfig 0.28 (24-Jan-2013): http://redmine.audacious-media-player.org/boards/1/topics/736 And the max available version for CentOS 7 in yum-repo and rpmfind.net is: pkgconfig-0.27.1-4.el7 http://rpmfind.net/linux/rpm2html/search.php?query=pkgconfig&submit=Search+...&system=centos&arch= I updated my pkgconfig to 0.30, but still failed at above error. (Maybe it is my setting problem) To make user in centos 6 and 7 building btrfs-progs without more changes, we can avoid using PKG_CHECK_VAR in following way found in: https://github.com/audacious-media-player/audacious-plugins/commit/f95ab6f939ecf0d9232b3165f9241d2ea9676b9e Signed-off-by: Zhao Lei <zhaolei@cn.fujitsu.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 68a37012..6b68c090 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,7 +124,8 @@ PKG_STATIC(UUID_LIBS_STATIC, [uuid])
PKG_CHECK_MODULES(ZLIB, [zlib])
PKG_STATIC(ZLIB_LIBS_STATIC, [zlib])
-PKG_CHECK_VAR([UDEVDIR], [udev], [udevdir])
+UDEVDIR="$(pkg-config udev --variable=udevdir)"
+AC_SUBST(UDEVDIR)
dnl lzo library does not provide pkg-config, let use classic way
AC_CHECK_LIB([lzo2], [lzo_version], [