summaryrefslogtreecommitdiff
path: root/debian/local/btrfs.hook
diff options
context:
space:
mode:
authorNicholas D Steeves <nsteeves@gmail.com>2016-04-23 00:41:30 +0100
committerNicholas D Steeves <nsteeves@gmail.com>2016-04-23 00:41:30 +0100
commitcec572daccafa1e912cbed363df6f84687778c6f (patch)
tree7d99ab9f73d25c1ed8eaf6393f6374edf5316b03 /debian/local/btrfs.hook
btrfs-progs (4.4.1-1.1) unstable; urgency=medium
* Non-maintainer upload. * New upstream release. * Rename package to btrfs-progs (Closes: #780081) * Update standards version to 3.9.7 (no changes needed). * debian/control: Add "Breaks" per Gianfranco Costamagna's suggestion * Change lintian override to reflect package rename * Switch from using postinst and postrm to using triggers per Christian Seiler's recommendation. # imported from the archive
Diffstat (limited to 'debian/local/btrfs.hook')
-rw-r--r--debian/local/btrfs.hook29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/local/btrfs.hook b/debian/local/btrfs.hook
new file mode 100644
index 00000000..d31199cb
--- /dev/null
+++ b/debian/local/btrfs.hook
@@ -0,0 +1,29 @@
+#!/bin/sh
+
+set -e
+
+PREREQ=""
+
+prereqs()
+{
+ echo "${PREREQ}"
+}
+
+case "${1}" in
+ prereqs)
+ prereqs
+ exit 0
+ ;;
+esac
+
+. /usr/share/initramfs-tools/hook-functions
+
+if [ -x /bin/btrfs ]
+then
+ copy_exec /bin/btrfs /bin
+ copy_exec /bin/btrfs-zero-log
+ if [ ! -x /usr/share/initramfs-tools/hooks/fsck ] && [ ! -x /etc/initramfs-tools/hooks/fsck ]
+ then
+ copy_exec /bin/fsck.btrfs /bin
+ fi
+fi