summaryrefslogtreecommitdiff
path: root/debian/patches/cross.patch
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2017-02-13 11:39:13 +0000
committerDimitri John Ledkov <xnox@ubuntu.com>2017-02-13 11:39:13 +0000
commitcaab40c947af8c0ddcc54d8fe7ebeb2a9de7b95e (patch)
tree9a2d71a60d04d6dd2c19d59d029670e4310885e5 /debian/patches/cross.patch
parent6364deedc63a2b29ae30c66f792017d05de71977 (diff)
Fix FTCBFS: cross.patch: Indirect pkg-config invocations through $PKG_CONFIG and autoreconf (Closes: #845816)
Diffstat (limited to 'debian/patches/cross.patch')
-rw-r--r--debian/patches/cross.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/cross.patch b/debian/patches/cross.patch
new file mode 100644
index 00000000..b78bdbea
--- /dev/null
+++ b/debian/patches/cross.patch
@@ -0,0 +1,32 @@
+From: Helmut Grohne <helmut@subdivi.de>
+Subject: use PKG_PROG_PKG_CONFIG correctly
+
+Using $PKG_CONFIG allows PKG_PROG_PKG_CONFIG to add $ac_tool_prefix which is
+crucial for cross compilation.
+
+Index: btrfs-progs-4.7.3/configure.ac
+===================================================================
+--- btrfs-progs-4.7.3.orig/configure.ac
++++ btrfs-progs-4.7.3/configure.ac
+@@ -55,8 +55,8 @@
+ dnl Calls pkg-config --static
+ dnl
+ AC_DEFUN([PKG_STATIC], [
+- if AC_RUN_LOG([pkg-config --exists --print-errors "$2"]); then
+- $1=`pkg-config --libs --static "$2"`
++ if AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$2"]); then
++ $1=`$PKG_CONFIG --libs --static "$2"`
+ AC_SUBST([$1])
+ else
+ AC_MSG_ERROR([pkg-config description of $2, needed for static build, is not available])
+@@ -165,8 +165,8 @@
+ # Our udev rule gives us the friendly dm names but isn't required (or valid)
+ # on earlier releases.
+ UDEVDIR=
+-if pkg-config udev --atleast-version 190; then
+- UDEVDIR="$(pkg-config udev --variable=udevdir)"
++if $PKG_CONFIG udev --atleast-version 190; then
++ UDEVDIR="$($PKG_CONFIG udev --variable=udevdir)"
+ fi
+ AC_SUBST(UDEVDIR)
+