summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2018-04-21 12:04:01 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2018-04-21 12:04:01 +0100
commitdab6d2181f1f194ec3a76d900cf2c6533379cbea (patch)
treeb47990a375ed0edf770a78906345ff63a1bc60be /debian/rules
parentb70cb0d0a21394d5d6b00b51f064115c2724cea8 (diff)
Dynamically detect and enable zstd support.debian/4.15.1-2archive/debian/4.15.1-2
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d797ac8f..d5f052a5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,8 @@ SHELL := sh -e
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
CFLAGS := $(patsubst -O2,-Os,$(CFLAGS))
+ZSTD := $(shell grep '^udeb: ' /var/lib/dpkg/info/libzstd*.shlibs)
+
%:
dh ${@} --with bash-completion
@@ -19,7 +21,11 @@ override_dh_autoreconf:
dh_autoreconf ./autogen.sh
override_dh_auto_configure:
- dh_auto_configure -- --bindir=/bin --disable-convert
+ifneq (,$(ZSTD))
+ dh_auto_configure -- --bindir=/bin --disable-convert --enable-zstd
+else
+ dh_auto_configure -- --bindir=/bin --disable-convert --disable-zstd
+endif
override_dh_auto_build:
dh_auto_build -- V=1