summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2018-05-14 13:25:40 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2018-05-14 13:25:40 +0100
commitea344a3ed2ac0eedda857656a6620914b143d4cd (patch)
tree831769f5ecba201116262c28533fde757f327a9c /debian/rules
parent477dd8ce890fe85f4e7b01a67517d0076dc2d9cc (diff)
Package libbtrfs, libbtrfsutil, and python bindings.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index d5f052a5..0314608e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,7 +15,7 @@ CFLAGS := $(patsubst -O2,-Os,$(CFLAGS))
ZSTD := $(shell grep '^udeb: ' /var/lib/dpkg/info/libzstd*.shlibs)
%:
- dh ${@} --with bash-completion
+ dh ${@} --with bash-completion,python3
override_dh_autoreconf:
dh_autoreconf ./autogen.sh
@@ -31,7 +31,7 @@ override_dh_auto_build:
dh_auto_build -- V=1
override_dh_auto_install:
- dh_auto_install --destdir=debian/btrfs-progs
+ dh_auto_install -- install install_python
# Adding initramfs-tools integration
install -D -m 0755 debian/local/btrfs.hook debian/btrfs-progs/usr/share/initramfs-tools/hooks/btrfs
@@ -40,6 +40,10 @@ override_dh_auto_install:
# Needs autopkgtest
override_dh_auto_test:
+override_dh_install:
+ dh_install
+ dh_missing --list-missing
+
override_dh_strip:
dh_strip --dbgsym-migration='btrfs-progs (<< 4.11.1+dfsg-1~)'