summaryrefslogtreecommitdiff
path: root/man/Makefile
diff options
context:
space:
mode:
authorghigo <ghigo@kreijack.homelinux.net>2010-01-24 18:00:05 +0100
committerChris Mason <chris.mason@oracle.com>2010-03-11 13:45:47 -0500
commit6d2cf042471cc728b5399b2beae54603739bc66a (patch)
tree0d8ea823ec7c1e4676630153eee998cc6fcfb62c /man/Makefile
parent06cbf62fda156d1399022158d671353d1a3aeaec (diff)
new util: 'btrfs'
This commit introduces a new command called 'btrfs' for managing a btrfs filesystem. 'btrfs' handles: - snapshot/subvolume creation - adding/removal of volume (ie: disk) - defragment of a tree - scan of a device searching a btrfs filesystem - re-balancing of the chunk on the disks - listing subvolumes and snapshots This has also been updated to include the new defrag range ioctl. Signed-off-by: Chris Mason <chris.mason@oracle.com>
Diffstat (limited to 'man/Makefile')
-rw-r--r--man/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/man/Makefile b/man/Makefile
index 4e8893b2..4a90b759 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -7,13 +7,16 @@ mandir = $(prefix)/man
man8dir = $(mandir)/man8
MANPAGES = mkfs.btrfs.8.gz btrfsctl.8.gz btrfsck.8.gz btrfs-image.8.gz \
- btrfs-show.8.gz
+ btrfs-show.8.gz btrfs.8.gz
all: $(MANPAGES)
mkfs.btrfs.8.gz: mkfs.btrfs.8.in
$(GZIP) -n -c mkfs.btrfs.8.in > mkfs.btrfs.8.gz
+btrfs.8.gz: btrfs.8.in
+ $(GZIP) -n -c btrfs.8.in > btrfs.8.gz
+
btrfsctl.8.gz: btrfsctl.8.in
$(GZIP) -n -c btrfsctl.8.in > btrfsctl.8.gz