summaryrefslogtreecommitdiff
path: root/man/Makefile
diff options
context:
space:
mode:
authorChristian Hesse <list@eworm.de>2013-01-22 15:51:19 -0500
committerDavid Sterba <dsterba@suse.cz>2013-01-23 18:37:44 +0100
commitcdbe16b3093aa565330a14860f307ac91e0310e7 (patch)
tree4b5dd5acdf74ed80f267082898a9453e6a232698 /man/Makefile
parentf2270bec863c4ca43dd1b69a939f45b082f83961 (diff)
btrfs-progs: fix build, manpage compression command
man pages for btrfs-progs are compressed by gzip by default. In Makefile the variable GZIP is use, this evaluates to 'gzip gzip' on my system. From man gzip: > The environment variable GZIP can hold a set of default options for gzip. > These options are interpreted first and can be overwritten by explicit > command line parameters. So using any other variable name fixes this. Patch is attached. Signed-off-by: Christian Hesse <list@eworm.de> Signed-off-by: Gene Czarcinski <gene@czarc.net>
Diffstat (limited to 'man/Makefile')
-rw-r--r--man/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/man/Makefile b/man/Makefile
index 4a90b759..f7b57f75 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -1,4 +1,4 @@
-GZIP=gzip
+GZIPCMD=gzip
INSTALL= install
prefix ?= /usr/local
@@ -12,22 +12,22 @@ MANPAGES = mkfs.btrfs.8.gz btrfsctl.8.gz btrfsck.8.gz btrfs-image.8.gz \
all: $(MANPAGES)
mkfs.btrfs.8.gz: mkfs.btrfs.8.in
- $(GZIP) -n -c mkfs.btrfs.8.in > mkfs.btrfs.8.gz
+ $(GZIPCMD) -n -c mkfs.btrfs.8.in > mkfs.btrfs.8.gz
btrfs.8.gz: btrfs.8.in
- $(GZIP) -n -c btrfs.8.in > btrfs.8.gz
+ $(GZIPCMD) -n -c btrfs.8.in > btrfs.8.gz
btrfsctl.8.gz: btrfsctl.8.in
- $(GZIP) -n -c btrfsctl.8.in > btrfsctl.8.gz
+ $(GZIPCMD) -n -c btrfsctl.8.in > btrfsctl.8.gz
btrfsck.8.gz: btrfsck.8.in
- $(GZIP) -n -c btrfsck.8.in > btrfsck.8.gz
+ $(GZIPCMD) -n -c btrfsck.8.in > btrfsck.8.gz
btrfs-image.8.gz: btrfs-image.8.in
- $(GZIP) -n -c btrfs-image.8.in > btrfs-image.8.gz
+ $(GZIPCMD) -n -c btrfs-image.8.in > btrfs-image.8.gz
btrfs-show.8.gz: btrfs-show.8.in
- $(GZIP) -n -c btrfs-show.8.in > btrfs-show.8.gz
+ $(GZIPCMD) -n -c btrfs-show.8.in > btrfs-show.8.gz
clean :
rm -f $(MANPAGES)