summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--tests/fsck-tests.sh11
2 files changed, 11 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 04d2c37d..e1b0a88c 100644
--- a/Makefile
+++ b/Makefile
@@ -140,7 +140,7 @@ $(BUILDDIRS):
@echo "Making all in $(patsubst build-%,%,$@)"
$(Q)$(MAKE) $(MAKEOPTS) -C $(patsubst build-%,%,$@)
-test:
+test: btrfs btrfs-convert btrfs-image btrfs-corrupt-block
$(Q)for t in $(TESTS); do \
echo " [TEST] $$t"; \
bash tests/$$t || exit 1; \
diff --git a/tests/fsck-tests.sh b/tests/fsck-tests.sh
index 285bcf65..24fb1090 100644
--- a/tests/fsck-tests.sh
+++ b/tests/fsck-tests.sh
@@ -22,10 +22,19 @@ run_check()
"$@" >> $RESULT 2>&1 || _fail "failed: $@"
}
+check_prereq()
+{
+ if ! [ -f $here/$1 ]; then
+ _fail "Failed prerequisities: $1";
+ fi
+}
+
rm -f $RESULT
# test rely on corrupting blocks tool
-run_check make btrfs-corrupt-block
+check_prereq btrfs-corrupt-block
+check_prereq btrfs-image
+check_prereq btrfs
# Some broken filesystem images are kept as .img files, created by the tool
# btrfs-image, and others are kept as .tar.xz files that contain raw filesystem