summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.in10
-rw-r--r--configure.ac2
2 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.in b/Makefile.in
index f3da51d8..0b92844b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -10,12 +10,14 @@ INSTALL = @INSTALL@
DISABLE_DOCUMENTATION = @DISABLE_DOCUMENTATION@
DISABLE_BTRFSCONVERT = @DISABLE_BTRFSCONVERT@
-# Non-static compilation flags
+# Common build flags
CFLAGS = @CFLAGS@ \
- -include config.h -Wall \
- -D_FILE_OFFSET_BITS=64 -DBTRFS_FLAT_INCLUDES \
+ -include config.h \
+ -D_FILE_OFFSET_BITS=64 \
+ -DBTRFS_FLAT_INCLUDES \
-D_XOPEN_SOURCE=700 \
- -fno-strict-aliasing -fPIC \
+ -fno-strict-aliasing \
+ -fPIC \
-rdynamic
LDFLAGS = @LDFLAGS@
diff --git a/configure.ac b/configure.ac
index 37bb18c0..d059e1c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,7 +8,7 @@ LIBBTRFS_MAJOR=0
LIBBTRFS_MINOR=1
LIBBTRFS_PATCHLEVEL=1
-CFLAGS=${CFLAGS:-"-g -O1"}
+CFLAGS=${CFLAGS:-"-g -O1 -Wall"}
AC_SUBST([CFLAGS])
AC_PREREQ([2.60])