summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--tests/fssum.c8
2 files changed, 2 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 2e25f6cc..3a713d3f 100644
--- a/Makefile
+++ b/Makefile
@@ -469,7 +469,7 @@ library-test.static: library-test.c messages.static.o $(libs_static)
fssum: tests/fssum.c
@echo " [LD] $@"
# FIXME: no configure-time check for libcrypto from SSL
- $(Q)$(CC) $(CFLAGS) -o $@ $< -D__LINUX__ $(LDFLAGS) -lcrypto
+ $(Q)$(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) -lcrypto
test-build: test-build-pre test-build-real
diff --git a/tests/fssum.c b/tests/fssum.c
index c26d32b9..ebfecf53 100644
--- a/tests/fssum.c
+++ b/tests/fssum.c
@@ -15,13 +15,12 @@
* Free Software Foundation, Inc., 59 Temple Place - Suite 330,
* Boston, MA 021110-1307, USA.
*/
-#ifdef __LINUX__
+
#define _BSD_SOURCE
#define _LARGEFILE64_SOURCE
#ifndef _GNU_SOURCE
#define _GNU_SOURCE
#endif
-#endif
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
@@ -31,9 +30,6 @@
#include <errno.h>
#include <sys/types.h>
#include <sys/stat.h>
-#ifdef __SOLARIS__
-#include <sys/mkdev.h>
-#endif
#include <openssl/md5.h>
#include <netinet/in.h>
#include <inttypes.h>
@@ -42,7 +38,6 @@
#define CS_SIZE 16
#define CHUNKS 128
-#ifdef __LINUX__
#ifndef SEEK_DATA
#define SEEK_DATA 3
#define SEEK_HOLE 4
@@ -53,7 +48,6 @@
#else
#define htonll(x) (x)
#endif
-#endif
/* TODO: add hardlink recognition */
/* TODO: add xattr/acl */