summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--btrfs-select-super.c2
-rw-r--r--check/main.c6
-rw-r--r--configure.ac2
-rw-r--r--convert/common.c2
-rw-r--r--image/main.c2
-rw-r--r--qgroup-verify.c2
-rw-r--r--transaction.c2
7 files changed, 9 insertions, 9 deletions
diff --git a/btrfs-select-super.c b/btrfs-select-super.c
index 0764bf01..67b3958d 100644
--- a/btrfs-select-super.c
+++ b/btrfs-select-super.c
@@ -34,7 +34,7 @@
static void print_usage(void)
{
printf("usage: btrfs-select-super -s number dev\n");
- printf("\t-s super copy of superbloc to overwrite the primary one (values: 1, 2)\n");
+ printf("\t-s super copy of superblock to overwrite the primary one (values: 1, 2)\n");
exit(1);
}
diff --git a/check/main.c b/check/main.c
index 682a2de9..730d2494 100644
--- a/check/main.c
+++ b/check/main.c
@@ -6871,7 +6871,7 @@ static int verify_backrefs(struct btrfs_fs_info *info, struct btrfs_path *path,
goto out;
fprintf(stderr,
- "attempting to repair backref discrepency for bytenr %llu\n",
+ "attempting to repair backref discrepancy for bytenr %llu\n",
rec->start);
/*
@@ -7851,7 +7851,7 @@ static int check_chunk_refs(struct chunk_record *chunk_rec,
dev_extent_rec->length != length) {
if (!silent)
fprintf(stderr,
- "Chunk[%llu, %u, %llu] stripe[%llu, %llu] dismatch dev extent[%llu, %llu, %llu]\n",
+"Chunk[%llu, %u, %llu] stripe[%llu, %llu] mismatch dev extent[%llu, %llu, %llu]\n",
chunk_rec->objectid,
chunk_rec->type,
chunk_rec->offset,
@@ -9484,7 +9484,7 @@ const char * const cmd_check_usage[] = {
"trees' consistency and item connectivity. In the repair mode try to",
"fix the problems found. ",
"WARNING: the repair mode is considered dangerous and should not be used",
- " without prior analysis of problems found on the flesystem."
+ " without prior analysis of problems found on the filesystem."
"",
"Options:",
" starting point selection:",
diff --git a/configure.ac b/configure.ac
index 55d540be..cf792eb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,7 +85,7 @@ fi
AC_ARG_ENABLE([documentation],
- AS_HELP_STRING([--disable-documentation], [do not build domumentation]),
+ AS_HELP_STRING([--disable-documentation], [do not build documentation]),
[], [enable_documentation=yes]
)
AS_IF([test "x$enable_documentation" = xyes], [DISABLE_DOCUMENTATION=0], [DISABLE_DOCUMENTATION=1])
diff --git a/convert/common.c b/convert/common.c
index b7674297..a9b24043 100644
--- a/convert/common.c
+++ b/convert/common.c
@@ -98,7 +98,7 @@ static int setup_temp_super(int fd, struct btrfs_mkfs_config *cfg,
if (*cfg->fs_uuid) {
if (uuid_parse(cfg->fs_uuid, super->fsid) != 0) {
- error("cound not parse UUID: %s", cfg->fs_uuid);
+ error("could not parse UUID: %s", cfg->fs_uuid);
ret = -EINVAL;
goto out;
}
diff --git a/image/main.c b/image/main.c
index c680ab19..39d5265d 100644
--- a/image/main.c
+++ b/image/main.c
@@ -2496,7 +2496,7 @@ int main(int argc, char *argv[])
} else {
if (walk_trees || sanitize != SANITIZE_NONE || compress_level) {
error(
- "useing -w, -s, -c options for restore makes no sense");
+ "using -w, -s, -c options for restore makes no sense");
usage_error++;
}
if (multi_devices && dev_cnt < 2) {
diff --git a/qgroup-verify.c b/qgroup-verify.c
index f5885589..3f2ce14a 100644
--- a/qgroup-verify.c
+++ b/qgroup-verify.c
@@ -1339,7 +1339,7 @@ int report_qgroups(int all)
if (counts.qgroup_inconsist && !counts.rescan_running &&
counts.rescan_running == 0) {
printf(
-"Rescan hasn't been initialzied, a difference in qgroup accounting is expected\n");
+"Rescan hasn't been initialized, a difference in qgroup accounting is expected\n");
skip_err = true;
}
if (counts.qgroup_inconsist && !counts.rescan_running)
diff --git a/transaction.c b/transaction.c
index 7baf7d58..e756db33 100644
--- a/transaction.c
+++ b/transaction.c
@@ -32,7 +32,7 @@ struct btrfs_trans_handle* btrfs_start_transaction(struct btrfs_root *root,
if (!h)
return ERR_PTR(-ENOMEM);
if (root->commit_root) {
- error("commit_root aleady set when starting transaction");
+ error("commit_root already set when starting transaction");
kfree(h);
return ERR_PTR(-EINVAL);
}