summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Documentation/Makefile4
-rw-r--r--Makefile7
2 files changed, 11 insertions, 0 deletions
diff --git a/Documentation/Makefile b/Documentation/Makefile
index eafbac7e..ef4f1bdc 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -91,6 +91,10 @@ install-man: man
$(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
$(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
+uninstall:
+ cd $(DESTDIR)$(man8dir); rm -f btrfs-check.8.gz $(GZ_MAN8)
+ rmdir -p --ignore-fail-on-non-empty $(DESTDIR)$(man8dir)
+
clean:
$(QUIET_RM)$(RM) *.xml *.xml+ *.5 *.5.gz *.8 *.8.gz
diff --git a/Makefile b/Makefile
index 3853b873..e721e99c 100644
--- a/Makefile
+++ b/Makefile
@@ -257,6 +257,13 @@ $(INSTALLDIRS):
@echo "Making install in $(patsubst install-%,%,$@)"
$(Q)$(MAKE) $(MAKEOPTS) -C $(patsubst install-%,%,$@) install
+uninstall:
+ $(Q)$(MAKE) $(MAKEOPTS) -C Documentation uninstall
+ cd $(DESTDIR)$(incdir); rm -f $(headers)
+ rmdir -p --ignore-fail-on-non-empty $(DESTDIR)$(incdir)
+ cd $(DESTDIR)$(libdir); rm -f $(lib_links) $(libs)
+ cd $(DESTDIR)$(bindir); rm -f btrfsck fsck.btrfs $(progs)
+
ifneq ($(MAKECMDGOALS),clean)
-include $(objects:.o=.o.d) $(cmd-objects:.o=.o.d) $(subst .btrfs,, $(filter-out btrfsck.o.d, $(progs:=.o.d)))
endif