summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Documentation/Makefile.in2
-rw-r--r--Documentation/btrfs-rescue.asciidoc24
-rw-r--r--cmds-rescue.c55
3 files changed, 79 insertions, 2 deletions
diff --git a/Documentation/Makefile.in b/Documentation/Makefile.in
index 695311dc..0c8b5ba9 100644
--- a/Documentation/Makefile.in
+++ b/Documentation/Makefile.in
@@ -10,7 +10,6 @@ MAN8_TXT += btrfs-image.asciidoc
MAN8_TXT += btrfs-map-logical.asciidoc
MAN8_TXT += btrfs-show-super.asciidoc
MAN8_TXT += btrfstune.asciidoc
-MAN8_TXT += btrfs-zero-log.asciidoc
MAN8_TXT += fsck.btrfs.asciidoc
MAN8_TXT += mkfs.btrfs.asciidoc
@@ -93,6 +92,7 @@ install-man: man
$(MV) $(DESTDIR)$(man5dir)/btrfs-mount.5.gz $(DESTDIR)$(man5dir)/btrfs.5.gz
$(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
$(LN_S) -f btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
+ $(LN_S) -f btrfs-rescue.8.gz $(DESTDIR)$(man8dir)/btrfs-zero-log.8.gz
uninstall:
cd $(DESTDIR)$(man8dir); rm -f btrfs-check.8.gz $(GZ_MAN8)
diff --git a/Documentation/btrfs-rescue.asciidoc b/Documentation/btrfs-rescue.asciidoc
index e0acf091..32d8a927 100644
--- a/Documentation/btrfs-rescue.asciidoc
+++ b/Documentation/btrfs-rescue.asciidoc
@@ -40,6 +40,30 @@ assume an answer of 'yes' to all questions.
-v::::
verbose mode.
+*zero-log* <device>::
+clear out log tree
+
+*btrfs rescue zero-log* will remove the log tree if log tree is corrupt, which
+will allow you to mount the filesystem again.
+
+The common case where this happens has been fixed a long time ago,
+so it is unlikely that you will see this particular problem.
+
+One can determine whether *btrfs-zero-log* is needed according to the kernel
+backtrace:
+----
+? replay_one_dir_item+0xb5/0xb5 [btrfs]
+? walk_log_tree+0x9c/0x19d [btrfs]
+? btrfs_read_fs_root_no_radix+0x169/0x1a1 [btrfs]
+? btrfs_recover_log_trees+0x195/0x29c [btrfs]
+? replay_one_dir_item+0xb5/0xb5 [btrfs]
+? btree_read_extent_buffer_pages+0x76/0xbc [btrfs]
+? open_ctree+0xff6/0x132c [btrfs]
+----
+
+If the errors are like above, then *zero-log* could be used to clear
+the log and the filesystem may be mounted normally again.
+
EXIT STATUS
-----------
*btrfs rescue* returns a zero exit status if it succeeds. Non zero is
diff --git a/cmds-rescue.c b/cmds-rescue.c
index ebe1dda3..64193678 100644
--- a/cmds-rescue.c
+++ b/cmds-rescue.c
@@ -19,6 +19,9 @@
#include "kerncompat.h"
#include <getopt.h>
+#include "ctree.h"
+#include "transaction.h"
+#include "disk-io.h"
#include "commands.h"
#include "utils.h"
@@ -149,11 +152,61 @@ int cmd_super_recover(int argc, char **argv)
return ret;
}
+const char * const cmd_rescue_zero_log_usage[] = {
+ "btrfs rescue zero-log <device>",
+ "Clear the tree log. Usable if it's corrupted and prevents mount.",
+ "",
+ NULL
+};
+
+int cmd_rescue_zero_log(int argc, char **argv)
+{
+ struct btrfs_root *root;
+ struct btrfs_trans_handle *trans;
+ struct btrfs_super_block *sb;
+ char *devname;
+ int ret;
+
+ if (check_argc_exact(argc, 2))
+ usage(cmd_rescue_zero_log_usage);
+
+ devname = argv[optind];
+ ret = check_mounted(devname);
+ if (ret < 0) {
+ fprintf(stderr, "Could not check mount status: %s\n", strerror(-ret));
+ goto out;
+ } else if (ret) {
+ fprintf(stderr, "%s is currently mounted. Aborting.\n", devname);
+ ret = -EBUSY;
+ }
+
+ root = open_ctree(devname, 0, OPEN_CTREE_WRITES | OPEN_CTREE_PARTIAL);
+ if (!root) {
+ fprintf(stderr, "Could not open ctree\n");
+ return 1;
+ }
+
+ sb = root->fs_info->super_copy;
+ printf("Clearing log on %s, previous log_root %llu, level %u\n",
+ devname,
+ (unsigned long long)btrfs_super_log_root(sb),
+ (unsigned)btrfs_super_log_root_level(sb));
+ trans = btrfs_start_transaction(root, 1);
+ btrfs_set_super_log_root(sb, 0);
+ btrfs_set_super_log_root_level(sb, 0);
+ btrfs_commit_transaction(trans, root);
+ close_ctree(root);
+
+out:
+ return !!ret;
+}
+
const struct cmd_group rescue_cmd_group = {
rescue_cmd_group_usage, NULL, {
{ "chunk-recover", cmd_chunk_recover, cmd_chunk_recover_usage, NULL, 0},
{ "super-recover", cmd_super_recover, cmd_super_recover_usage, NULL, 0},
- { 0, 0, 0, 0, 0 }
+ { "zero-log", cmd_rescue_zero_log, cmd_rescue_zero_log_usage, NULL, 0},
+ NULL_CMD_STRUCT
}
};