summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.in6
-rwxr-xr-xtests/fuzz-tests.sh41
2 files changed, 46 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index cc6ed59f..8e248086 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -205,11 +205,15 @@ test-mkfs: btrfs mkfs.btrfs
@echo " [TEST] mkfs-tests.sh"
$(Q)bash tests/mkfs-tests.sh
+test-fuzz: btrfs
+ @echo " [TEST] fuzz-tests.sh"
+ $(Q)bash tests/fuzz-tests.sh
+
test-clean:
@echo "Cleaning tests"
$(Q)bash tests/clean-tests.sh
-test: test-fsck test-mkfs test-convert test-misc
+test: test-fsck test-mkfs test-convert test-misc test-fuzz
#
# NOTE: For static compiles, you need to have all the required libs
diff --git a/tests/fuzz-tests.sh b/tests/fuzz-tests.sh
new file mode 100755
index 00000000..0e59832e
--- /dev/null
+++ b/tests/fuzz-tests.sh
@@ -0,0 +1,41 @@
+#!/bin/bash
+#
+# misc tests on fuzzed or crafted images
+
+unset TOP
+unset LANG
+LANG=C
+SCRIPT_DIR=$(dirname $(readlink -f $0))
+TOP=$(readlink -f $SCRIPT_DIR/../)
+TEST_DEV=${TEST_DEV:-}
+RESULTS="$TOP/tests/fuzz-tests-results.txt"
+IMAGE="$TOP/tests/test.img"
+
+source $TOP/tests/common
+
+export TOP
+export RESULTS
+export LANG
+export IMAGE
+
+rm -f $RESULTS
+
+check_prereq btrfs
+
+# The tests are driven by their custom script called 'test.sh'
+
+for i in $(find $TOP/tests/fuzz-tests -maxdepth 1 -mindepth 1 -type d \
+ ${TEST:+-name "$TEST"} | sort)
+do
+ name=$(basename $i)
+ cd $i
+ if [ -x test.sh ]; then
+ echo "=== Entering $i" >> $RESULTS
+ echo " [TEST] $name"
+ ./test.sh
+ if [ $? -ne 0 ]; then
+ _fail "test failed for case $(basename $i)"
+ fi
+ fi
+ cd $TOP
+done