summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Documentation/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Documentation/Makefile b/Documentation/Makefile
index e22f5bca..45299bb2 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -85,10 +85,11 @@ clean:
%.8 : %.xml
$(QUIET_XMLTO)$(RM) $@ && \
$(XMLTO) -m $(MANPAGE_XSL) $(XMLTO_EXTRA) man $<
-
%.xml : %.txt asciidoc.conf
- $(QUIET_ASCIIDOC)$(RM) $@+ $@ && \
+ $(QUIET_ASCIIDOC)$(RM) $@.tmp[12] $@ && \
+ sed -e "s/\(<[^>]\+>\)/'\1'/g" < $< > $@.tmp1 && \
$(ASCIIDOC) -b docbook -d manpage -f asciidoc.conf \
$(ASCIIDOC_EXTRA) -abtrfs_version=$(BTRFS_VERSION) \
- -o $@+ $< && \
- mv $@+ $@
+ -o $@.tmp2 $@.tmp1 && \
+ mv $@.tmp2 $@ && \
+ rm -f -- $@.tmp1