summaryrefslogtreecommitdiff
path: root/Documentation
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation')
-rw-r--r--Documentation/Makefile2
-rw-r--r--Documentation/btrfs-check.txt3
-rw-r--r--Documentation/btrfs-restore.txt2
-rw-r--r--Documentation/mkfs.btrfs.txt2
4 files changed, 6 insertions, 3 deletions
diff --git a/Documentation/Makefile b/Documentation/Makefile
index ec8598bb..e22f5bca 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -48,6 +48,7 @@ XMLTO_EXTRA = -m manpage-bold-literal.xsl
GZIP = gzip
INSTALL ?= install
RM ?= rm -f
+LNS ?= ln -sf
BTRFS_VERSION = $(shell sed -n 's/.*BTRFS_BUILD_VERSION "Btrfs \(.*\)"/\1/p'\
../version.h)
@@ -73,6 +74,7 @@ install: install-man
install-man: man
$(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
$(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
+ $(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)
clean:
$(RM) *.xml *.xml+ *.8 *.8.gz
diff --git a/Documentation/btrfs-check.txt b/Documentation/btrfs-check.txt
index ddd7fe77..485a49cb 100644
--- a/Documentation/btrfs-check.txt
+++ b/Documentation/btrfs-check.txt
@@ -18,6 +18,8 @@ command, it is *highly* recommended to read the following btrfs wiki before
executing 'btrfs check' with '--repair' option: +
https://btrfs.wiki.kernel.org/index.php/Btrfsck
+'btrfsck' is an alias of 'btrfs check' command and is now deprecated.
+
OPTIONS
-------
-s|--support <superblock>::
@@ -47,4 +49,3 @@ SEE ALSO
`mkfs.btrfs`(8),
`btrfs-scrub`(8),
`btrfs-rescue`(8)
-`btrfsck`(8)
diff --git a/Documentation/btrfs-restore.txt b/Documentation/btrfs-restore.txt
index 72aa0847..c1d1607a 100644
--- a/Documentation/btrfs-restore.txt
+++ b/Documentation/btrfs-restore.txt
@@ -14,7 +14,7 @@ DESCRIPTION
'btrfs restore' is used to try to salvage files from a damaged filesystem and
restore them into <path> or just list the tree roots.
-Since current `btrfsck`(8) or `btrfs-rescue`(8) only has very limited usage,
+Since current `btrfs-check`(8) or `btrfs-rescue`(8) only has very limited usage,
'btrfs restore' is normally a better choice.
NOTE: It is recommended to read the following btrfs wiki page if your data is
diff --git a/Documentation/mkfs.btrfs.txt b/Documentation/mkfs.btrfs.txt
index bafe0652..7ce00961 100644
--- a/Documentation/mkfs.btrfs.txt
+++ b/Documentation/mkfs.btrfs.txt
@@ -130,4 +130,4 @@ further details.
SEE ALSO
--------
-`btrfsck`(8)
+`btrfs`(8)