summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index 19697ffa..82a3143c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -379,9 +379,8 @@ install: $(libs) $(progs_install) $(INSTALLDIRS)
$(INSTALL) -m644 $(headers) $(DESTDIR)$(incdir)
install-static: $(progs_static) $(INSTALLDIRS)
- for p in $(progs_static) ; do \
- $(INSTALL) -D -m755 $$p $(DESTDIR)$(bindir)/ ; \
- done
+ $(INSTALL) -m755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) $(progs_static) $(DESTDIR)$(bindir)
# btrfsck is a link to btrfs in the src tree, make it so for installed file as well
$(LN_S) -f btrfs.static $(DESTDIR)$(bindir)/btrfsck.static