summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index f3da51d8..0b92844b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -10,12 +10,14 @@ INSTALL = @INSTALL@
DISABLE_DOCUMENTATION = @DISABLE_DOCUMENTATION@
DISABLE_BTRFSCONVERT = @DISABLE_BTRFSCONVERT@
-# Non-static compilation flags
+# Common build flags
CFLAGS = @CFLAGS@ \
- -include config.h -Wall \
- -D_FILE_OFFSET_BITS=64 -DBTRFS_FLAT_INCLUDES \
+ -include config.h \
+ -D_FILE_OFFSET_BITS=64 \
+ -DBTRFS_FLAT_INCLUDES \
-D_XOPEN_SOURCE=700 \
- -fno-strict-aliasing -fPIC \
+ -fno-strict-aliasing \
+ -fPIC \
-rdynamic
LDFLAGS = @LDFLAGS@