summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 3698d387..79dfcf5a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -446,10 +446,14 @@ test-ioctl: ioctl-test ioctl-test-32 ioctl-test-64
library-test: $(libs_shared) library-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o library-test library-test.o $(LDFLAGS) -lbtrfs
+ @echo " [TEST] $@"
+ $(Q)./$@
library-test.static: $(libs_static) library-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o library-test-static library-test.o $(LDFLAGS) $(libs_static)
+ @echo " [TEST] $@"
+ $(Q)./$@
test-build: test-build-pre test-build-real