summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 6febd94e..ac6b353b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -242,6 +242,12 @@ test-clean:
@echo "Cleaning tests"
$(Q)bash tests/clean-tests.sh
+test-inst: all
+ @tmpdest=`mktemp --tmpdir -d btrfs-inst.XXXXXX` && \
+ echo "Test installation to $$tmpdest" && \
+ $(MAKE) DESTDIR=$$tmpdest install && \
+ $(RM) -rf -- $$tmpdest
+
test: test-fsck test-mkfs test-convert test-misc test-fuzz
#