summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 8450ab3d..25b4038a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -344,8 +344,10 @@ install: $(libs) $(progs_install) $(INSTALLDIRS)
install-static: $(progs_static) $(INSTALLDIRS)
for p in $(progs_static) ; do \
- $(INSTALL) -D -m755 $$p $(DESTDIR)$(bindir)/`basename $$p .static` ; \
+ $(INSTALL) -D -m755 $$p $(DESTDIR)$(bindir)/ ; \
done
+ # btrfsck is a link to btrfs in the src tree, make it so for installed file as well
+ $(LN_S) -f btrfs.static $(DESTDIR)$(bindir)/btrfsck.static
$(INSTALLDIRS):
@echo "Making install in $(patsubst install-%,%,$@)"