summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74e62b40..f523ba5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,14 @@ if test "x$enable_documentation" = xyes; then
AC_PROG_SED
fi
+AC_ARG_ENABLE([convert],
+ AS_HELP_STRING([--disable-convert], [do not build btrfs-convert]),
+ [], [enable_btrfsconvert=yes]
+)
+
+AS_IF([test "x$enable_btrfsconvert" = xyes], [DISABLE_BTRFSCONVERT=0], [DISABLE_BTRFSCONVERT=1])
+AC_SUBST([DISABLE_BTRFSCONVERT])
+
dnl Define <NAME>_LIBS= and <NAME>_CFLAGS= by pkg-config
dnl