summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index d5f052a5..0314608e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,7 +15,7 @@ CFLAGS := $(patsubst -O2,-Os,$(CFLAGS))
ZSTD := $(shell grep '^udeb: ' /var/lib/dpkg/info/libzstd*.shlibs)
%:
- dh ${@} --with bash-completion
+ dh ${@} --with bash-completion,python3
override_dh_autoreconf:
dh_autoreconf ./autogen.sh
@@ -31,7 +31,7 @@ override_dh_auto_build:
dh_auto_build -- V=1
override_dh_auto_install:
- dh_auto_install --destdir=debian/btrfs-progs
+ dh_auto_install -- install install_python
# Adding initramfs-tools integration
install -D -m 0755 debian/local/btrfs.hook debian/btrfs-progs/usr/share/initramfs-tools/hooks/btrfs
@@ -40,6 +40,10 @@ override_dh_auto_install:
# Needs autopkgtest
override_dh_auto_test:
+override_dh_install:
+ dh_install
+ dh_missing --list-missing
+
override_dh_strip:
dh_strip --dbgsym-migration='btrfs-progs (<< 4.11.1+dfsg-1~)'